You might want to think long and hard before you unlock that iOS 4.2.1 device. According to The Big Boss, Apple has decided to put a baseband requirement on iOS.

This means that another hurdle has been thrown directly at your feet while you’re trying to unlock your device. According to the site,

Apple has decided to put a baseband requirement on iOS. So at this point, if you are using Saurik’s server or tiny umbrella and trying to restore 4.2.1 on an iPhone 4, you will end up in recovery mode and tiny umbrella will not be able to pull you out of recovery. In this case, you will have to restore 4.1 again or you will have to restore 4.2.1 stock and be tether jailbroken. (Of course, I recommend 4.1 and not bothering with 4.2.1 at all). If you are an unlocker, this is a no brainer. Do not update to 4.2.1 even to test it at this point.

If you’re thinking about getting your unlock on, we’d suggest waiting.

Hopefully we will see a resolution sooner rather than later.

Article Via The Big Boss

Comments are closed.